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 Introduction

What is eMessenger?
eMessenger combines the freedom of a wireless phone system with the 
convenience and speed of on-site paging by providing for automatic alpha-
numeric paging to wireless telephones. A windows-based system, 
eMessenger controls the open application interface (OAI) to the 
SpectraLink System. 

The components of eMessenger are:

• eMessenger Server
• eMessenger Paging Client
• eMessenger TAP Pager Winsocket Server
• eMessenger E-mail Client
• eMessenger E-mail Response
• eMessenger E-mail Directory
• eMessenger Lookup
• eMessenger LAN Client
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Product Description

eMessenger Server
The eMessenger Server is the communications gateway and physical 
interface to the SpectraLink system. The eMessenger Server manages the 
handling of messages to and from the SpectraLink wireless telephone. The 
eMessenger software package provides immediate connectivity to various 
messaging applications.

eMessenger Paging Client
The Paging Client delivers alpha-numeric messages to SpectraLink wireless 
telephones from on-site paging systems. Messages can be generated by a 
wide variety of sources, including alpha-numeric paging terminals, 
monitoring equipment, security systems, and industrial control devices.

eMessenger TAP Pager Winsocket Server
The eMessenger TAP Pager Winsocket Server receives pages from off-site 
paging devices and forwards them on to the eMessenger Server for delivery 
to a pager. eMessenger supports ASCII, TAPI, Rock, JTech, and Alert pager 
device protocols.

eMessenger E-mail Client
The E-mail Client forwards a message to a SpectraLink wireless telephone 
from the internet, your company’s intranet, or your local network. Using 
standard e-mail software, the E-mail Client delivers messages to any 
wireless telephone extension.

eMessenger E-mail Response
When an e-mail message is delivered to a SpectraLink wireless telephone 
and viewed by the user, the eMessenger E-mail Response sends an 
acknowledgement e-mail message to the sender. 
apter 1 V.1.63H



eMessenger Directory
You can create a customized telephone directory for your SpectraLink 
wireless telephone users with the eMessenger Directory. The eMessenger 
Directory provides the SpectraLink wireless telephone user with a mobile 
address book containing frequently-called numbers.

eMessenger Lookup
You can configure the eMessenger Lookup database to find the number of 
the phone in the location from which eMessenger receives a page generated 
from an in-room call system. When eMessenger Lookup receives the page, 
it checks to see if the page contains data or symbols that match a delivery 
rule. If the page meets a rule’s criteria, eMessenger Lookup forwards the 
delivery information to the eMessenger Server. The SpectraLink wireless 
telephone user is then connected to the room originating the page.

eMessenger LAN Client
With the LAN Client, SpectraLink wireless telephone users can receive a 
text message from a networked PC. From the eMessenger application 
window, the sender selects the recipient’s name or phone number and types 
the message. 

Other IP applications
Because the eMessenger Server acts as the communication gateway 
between messaging applications and the SpectraLink system, it can receive 
input from other IP-based applications and translate those messages for 
delivery to SpectraLink wireless telephones.

System Overview
The eMessenger Server can receive messages from multiple sources: 
networked PC’s with the eMessenger client, e-mail applications, paging 
controllers, and other IP applications. Any, or all, of these messaging 
options can be implemented with a single eMessenger Server.

The eMessenger Server uses a serial interface to communicate with the 
SpectraLink system controller.
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Messages arriving from the LAN client, an e-mail application or another IP 
application are delivered to the eMessenger Server through an interface on 
the local or wide area network.

In addition, eMessenger can accept messages from any paging system that 
generates TAP (Telocator Alpha-numeric Protocol) formatted messages. 
TAP is a standard protocol for in-house radio paging systems. Messages 
arriving from a paging system are sent over a serial interface.
apter 1 V.1.63H
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 Installation

System Specifications

Operating System
Windows 95, Windows, 98, Windows ME, or Windows NT operating 
system is required.

Hardware
• Pentium II 300 MHz CPU or higher with 128 megabytes of RAM
• Hard disk with 4 gigabytes of free space
• 3.5-inch disk drive
• One parallel printer port
• Two RS232 serial communication ports (One port connects to the 

telephone interface; the other port connects to the TAP paging system
• Monitor with SVGA display and 800x600 resolution
• Mouse or other Windows pointing device
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Installation Instructions
Note: Before installing eMessenger, make a backup disk set.

Start Windows and insert the eMessenger disk 1 into the floppy disk drive.

1 From the Start menu, choose Run.
2 In the Open box, type a:\setup.exe (where a:\ is the letter of the drive 

containing the eMessenger disk).
3 Click OK to display the eMessenger installation menu.

eMessenger installation menu

4 Choose the component you want to install and then click OK.
5 When prompted, put disk 2 in the drive and click OK.

The installation utility allows the user to install any of the eMessenger 
program components. Repeat these steps to install each component.

With the exception of the eMessenger LAN Client, all of the components 
may be installed on the same PC. The eMessenger LAN Client is installed 
on the PC used by those wanting to send text messages to SpectraLink 
wireless telephone users.

The program includes the programs in the StartUp menu. If you do not want 
eMessenger to start automatically, delete the shortcut icons for the 
eMessenger components in your StartUp list.
apter 2 V.1.63H
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 Getting Started

Start eMessenger Server to view the status screen and menu bar.
eMessenger Server Status Screen

From the eMessenger Server menu bar, you can:

• set system parameters
• create and edit the eMessenger directory
• import a new directory or export the existing directory
• define user groups
• provision eMessenger’s Directory, Lookup, and E-mail applications
• configure communications settings
• monitor system activities
• send a page to test the eMessenger communication to the SpectraLink 

OAI
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Setting System Parameters

To set system parameters:

1 From the Edit menu, click Options to display the Options dialog box.

2 In the System Type list, select your SpectraLink system model.
3 Enter an amount in the Connect timeout In Seconds box.
4 Select a Ring Type.
5 Define Retry Parameters
6 Click OK.

By selecting the correct system type your eMessenger software keeps a 
database of telephone extensions assigned to physical port numbers. The 
options include the SpectraLink model 150, model 2000 single cabinet 
(2000S) or multiple cabinet (2000M) and the model 3000. 

Note: the System Type should not change unless you upgrade your 
SpectraLink hardware. If you change your system type you will overwrite 
your eMessenger directory.

Connect Timeout in Seconds
Connect timeout indicates the amount of time that the eMessenger 
application is inactive on a wireless telephone before it automatically exits 
the eMessenger application. If a user does not perform an eMessenger 
activity on their wireless telephone within the defined period, the telephone 
will automatically return to standby mode so that it can receive a telephone 
call or another eMessenger message.
apter 3 V.1.63H



Ring Type
The administrator can set the ring type for eMessenger users. This is a global 
parameter - it will affect all system users. By selecting a specific ring type, 
all eMessenger user’s wireless telephones will ring in the selected manner 
when a message is delivered. By selecting Telephone Ring, eMessenger will 
ring the telephone the same as the ring for a telephone call. This option is 
not advised because users will not be able to easily differentiate between 
calls or messages. Auxiliary Ring 1 allows the SpectraLink telephone user 
to set their own ring type for the eMessenger ring.

Retry Parameters
The administrator can determine the retry interval in seconds and the 
number of retry attempts for the eMessenger system. This is a global setting 
for all users. If eMessenger is unable to ring the wireless telephone to 
indicate a new message has arrived, it will follow the retry settings. A 
telephone may be unreachable because it is turned off, out of range, on a 
telephone call, in an eMessenger session or ringing. If eMessenger attempts 
to ring the telephone and it goes unanswered, the message will still be 
delivered to the user’s eMessenger queue and notification attempts (retries) 
will occur.

Setting up the eMessenger Directory
The eMessenger Directory is a database that cross-references the user’s 
physical port in the SpectraLink system with a user’s name and telephone 
extension. eMessenger delivers messages based on the telephone extension, 
not port number. When a message is sent, the sender selects the user’s name 
or telephone number/extension and eMessenger sends it to the correct 
physical port.

Note: Before creating or editing the eMessenger directory, define your 
SpectraLink system type (see “Setting System Parameters” on page 8).
Getting Started 9 
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Creating and Editing the Directory

To add a User:

1 From the Edit menu, click Directory to display the Directory dialog 
box. 

2 Click New to add a SpectraLink wireless telephone user.
Directory dialog box

3 Type the user’s Number/Extension, select a Ring Type, type the 
Master Control Unit (MCU) and Pocket Telephone (PT) ports (or press 
Tab for eMessenger to automatically calculate the port number), and 
enter user’s Name.To add a group name, enter the group’s extension, 
click the Group check box, and enter the group’s name.

4 Click Save. The user’s name and extension number will appear on the 
Directory list.

5 Click Exit to return to the eMessenger status screen.
hapter 3 V.1.63H



Fill in all available fields in the Directory window. Fields that are 
unavailable do not apply to your SpectraLink system type (for information 
about defining your SpectraLink system type in eMessenger, see “Setting 
System Parameters” on page 8). 

The MCU and PT fields are for the physical port on the SpectraLink system 
that corresponds to the information provided. The Port number is calculated 
by eMessenger. The port can not be edited and is different than the wireless 
telephone number field (referred to in this application by its former name, 
Pocket Telephone or PT). If you have further questions about configuration 
of the SpectraLink system, contact SpectraLink Customer Server directly at 
1-800-676-5465.

To delete a user:

1 In the eMessenger Directory window, click on the desired name to select 
it.

2 Click Delete. 
3 Click Yes to complete the action.

Importing/Exporting the Directory Database
The database can be imported or exported as an ASCII text file with comma-
delimited fields. The user information can be edited in the text file as well 
as entered using the directory screen fields. Field values are contained 
within double quotation marks. Spaces are permitted in the Name field 
only.

The fields are:

• Name
• Extension Number
• Port Number
• Shelf Number
• slot
• Pocket Telephone
• Device Type
Getting Started 11 
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• Ring Type
Export the Directory to create a back-up copy of the Directory file. Import 
the file to restore the Directory.

Defining User Groups

To assign users to a group:

1 Add a group name to the eMessenger Directory (for information on how 
to add a group name to the eMessenger Directory, see “Creating and 
Editing the Directory” on page 10).

2 Click the box of the Group Name that appears to the right of the user’s 
name.

3 Click OK.

Edit Application Interface

To edit application interface:

1 From the Edit menu, click Applications to display the Edit 
Application Interface dialog box. 

2 Type the IP Address for Directory Application, Lookup Application, 
and Email Response Application.

3 Click OK.
hapter 3 V.1.63H



Changing Communications Settings
In the Communications Settings window, you can set the 
communications port number, the port’s baud rate, parity, data bits, and 
stop bits. 

To set up the Server’s communications settings:

1 From the eMessenger Server menu bar, click Options then Comm 
Settings.

Options Menu

2 In the Communications Settings dialog box, select the Port that 
connects your computer to the SpectraLink OAI.

3 Set the Baud rate (9600 is the default setting).
4 Set the Parity bit (none is the default setting).
5 Set the Data bits (8 is the default setting).
6 Set the Stop bits (1 is the default setting). 

Monitoring System Activity
To monitor system activity and capability, and display all data going to and 
from the communications port:

• From the Options menu, click Monitor Comm Port I/O.
Along with all system transactions, eMessenger sends “heartbeat” data at 
regular intervals and logs the activity on the Server display and text log 
(mlslog.txt).
Getting Started 13 
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Disk Logging saves all data to disk. To enable/disable this function:

• From the Options menu, click Disk Logging. 
When the mlslog.txt file reaches .5 MB, it is saved in the eMessenger Server 
directory with the date in the file name.

Sending a Test Page

To test communication between the Server and the SpectraLink OAI:

1 From the Commands menu, click Send Test Page.
2 Type the Port number or select Page Name or Page Number.
3 Click OK.

Clearing the Server Window
To clear the eMessenger Server window:

• From the Commands menu, click Clear Screen.
This action clears any output that is currently in the application window. 
Output display automatically continues.

Exit eMessenger Server
To exit eMessenger Server:

• From the File menu, click Exit.
eMessenger Server will shut down in 5 seconds.

Note: Exiting eMessenger Server shuts down the eMessenger system.
hapter 3 V.1.63H
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 eMessenger paging client

The Paging Client takes data input from an external TAP (Telocator Alpha-
numeric Protocol) paging system and delivers the data to the eMessenger 
Server. The connection between the PC running the Paging Client and the 
TAP system is a serial connection with a standard RS-232 cable. The Paging 
Client can be installed on the same PC as the eMessenger Server or a 
different LAN work station. The Paging Client recognizes the Server by IP 
address.

From the Paging Client window, the System Administrator can:

• set communications settings
• change the Server IP address
• monitor system activity.
On startup, the Paging Client window shows the current software version 
and indicates that the communication port to the paging system is correctly 
configured.

Setting Paging Client Communications Settings
The Communications Settings are configured based on the input from the 
external paging system.
15 
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To set the paging system parameters to match the paging system:

1 From the Options menu, click Comm Settings. 

2 In the Communications Settings dialog box, select the Port that 
connects your computer to the SpectraLink OAI.

3 Set the Baud rate (9600 is the default setting).
4 Set the Parity bit (none is the default setting).
5 Set the Data bits (8 is the default setting).
6 Set the Stop bits (1 is the default setting). 

Entering eMessenger Server IP Address
The Paging Client must reference the correct address of the eMessenger 
Server in order to forward messages to wireless telephones. Even if the 
Paging Client is on the same PC as the Server, you still must input the IP 
address of that PC.

If the only client you are using is the Paging Client, the PC does not have to 
be on a LAN - all connections are serial. However, the computer does 
require a static IP address.

To change the Server IP address from the Paging Client:

1 From the Options menu, click Edit IP Addresses.
2 Type the correct IP Address in the eMessenger Server IP Address 

field.
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3 Select Copy Pages, define the filter, and enter an IP Address to forward 
a copy of pages to another location.

4 Click OK.

Monitoring System Activity
To monitor system activity and capability, and display all data going to and 
from the communications port:

• From the Options menu, click Monitor Comm Port I/O.
Disk Logging saves all data to disk. To enable/disable this function:

• From the Options menu, click Disk Logging. 
Display Debug Data shows additional information about the operation of the 
program. To enable/disable this function:

• From the Options menu, click Display Debug Data.

Clearing the Paging Client Applications Window
To clear the eMessenger Paging Client window:

• From the Commands menu, click Clear Screen.
This action clears any output that is currently in the application window. 
Output display automatically continues.
eMessenger paging client 17 
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 eMessenger E-mail Client

Setting up the E-mail Client for users
The E-mail Client uses standard e-mail software to forward messages to 
SpectraLink wireless telephone extensions. Messages are received from the 
internet, the company’s intranet, or a local/wide area network.

Operation of the E-mail Client requires a separate mailbox for all e-mail 
messages destined for wireless telephones. Messages that are sent via e-mail 
must contain the extension of the wireless telephone somewhere in the 
address or subject field. This ensures proper destination based on the 
eMessenger configuration

To set up E-mail Client parameters:

1 From the Edit menu, click Options.

2 In the Options dialog box, type the name of the mail server in the Mail 
Server field.

3 Type the eMessenger mailbox name in User Name field.
4 Type the assigned password for the mailbox in the Password field.
19 
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5 Type the frequency with which the E-mail Client should check for new 
messages in the eMessenger mailbox in the Monitor Interval field.

6 Type the address of the eMessenger Server computer in the eMessenger 
IP Address field.

7 Select a Pager ID Location in e-mail. This setting will determine 
where the system looks for the telephone extension and therefore, how 
the sender addresses messages destined for wireless telephones. 
Depending on the e-mail server software or customer preferences, the 
pager ID information is passed differently from the e-mail application. 
The Administrator can choose the following ID location options:
• Alias—Create an alias for each wireless telephone user/extension 

associated with the eMessenger mailbox name (User Name field). The 
E-mail Client program must receive the alias when it retrieves mail.

• To Line or Subject—Choose to have users embed the telephone 
user/extension within the address book entry [which becomes the To line 
in mail, e.g.: Joe Samson (4128)]. Because some e-mail servers resolve 
the To line with the global address list, with this setting you can also 
choose to have the user embed the extension within the subject line, e.g.: 
Subject: News of the day (4128).

• To Name Routing—When the name is included in the address, 
eMessenger routes based on the name rather than the number.

Disk Logging and Display Debug Data
Disk Logging saves all data to disk. To enable/disable this function:

• From the Options menu, click Disk Logging. 
Display Debug Data shows additional information about the operation of the 
program. To enable/disable this function:

• From the Options menu, click Display Debug Data.

Checking E-mail Manually
To manually check e-mail:

• From Commands menu, click Check Mail. 
hapter 5 V.1.63H



Clearing the E-Mail Client Applications Window
To clear the eMessenger E-mail Client window:

• From the Commands menu, click Clear Screen.
This action clears any output that is currently in the application window. 
Output display automatically continues.
eMessenger E-mail Client 21 
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 eMessenger TAP Pager

The eMessenger TAP Pager forwards pages from a paging system to the 
user’s pager. 

To select the paging device protocol:

1 From the Options menu, click Select Pager Device.
2 Select the correct pager device protocol.
3 Click OK.

In the Communications Settings window, you can set the 
communications port number, the port’s baud rate, parity, data bits, and 
stop bits. 

To set up the TAP Pager communications settings:

1 From the eMessenger Server menu bar, choose Options then Comm 
Settings.

2 In the Communications Settings window, select the Port that connects 
your computer to the SpectraLink OAI.

3 Set the Baud rate (9600 is the default setting).
4 Set the Parity bit (none is the default setting).
5 Set the Data bits (8 is the default setting).
6 Set the Stop bits (1 is the default setting). 
23 
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Monitoring System Activity
To monitor system activity and capability, and display all data going to and 
from the communications port:

• from the Options menu, click Monitor Comm Port I/O.
Disk Logging saves all data to disk. To enable/disable this function:

• from the Options menu, click Disk Logging. 
When the ipglog.txt file reaches .5 MB, it is saved in the eMessenger Server 
directory with the date in the file name.

Display Pager Traffic shows paging activity. To enable/disable this function:

• from the Options menu, click Display Pager Traffic.

Clearing the Pager Winsocket Server Process Window
To clear the Pager Winsocket Server Process window:

• From the Commands menu, click Clear Screen.
This action clears any output that is currently in the application window. 
Output display automatically continues.
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 eMessenger Lookup

eMessenger Lookup uses an internal database to connect the SpectraLink 
wireless telephone user with the room from which a message is generated 
through the in-room call button. 

Setting up the Lookup Directory

To set up the Lookup Directory:

1 From the Edit menu, click Lookup Directory.
2 Click New.
3 Type the name or identifier.
4 Type the number.
5 Click Save.

Export the Directory to create a text file. This file may be used as a backup 
directory. Restore the Directory by importing the backup file.

Defining Lookup Rules

To define the rules:

1 From the Edit menu, click Options.
2 Select the rule and defining part of the message.
3 Click OK.
25 
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Monitoring System Activity
Disk Logging saves all data to disk. To enable/disable this function:

• From the Options menu, click Disk Logging. 
When the mlllog.txt file reaches .5 MB, it is saved in the eMessenger Server 
directory with the date in the file name.

Display Debug Data provides more information about system operation. To 
enable/disable this function:

• From the Options menu, click Display Debug Data.

Clearing the eMessenger Lookup Window
To clear the eMessenger Lookup window:

• From the Commands menu, click Clear Screen.
This action clears any output that is currently in the application window. 
Output display automatically continues.
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 eMessenger E-mail Response

When the SpectraLink wireless telephone user receives and views an e-mail 
message, the eMessenger E-mail Response notifies the sender that the user 
received the message.

Configuring eMessenger E-mail Response

To configure the eMessenger E-mail Response:

1 From the Edit menu, click Options to display the Options dialog box.

2 Enter the Mail Server.
3 Enter the From Email Address
4 Click OK.

eMessenger responds to the sender with “received your email” to messages 
sent to the From Email Address.

Monitoring System Activity
Disk Logging saves all data to disk. To enable/disable this function:

• From the Options menu, click Disk Logging. 
27 
• 
• 
• 
•
•
•



28  C

• 
• 
• 
•
•
•

When the mlmlog.txt file reaches .5 MB, it is saved in the eMessenger 
Server directory with the date in the file name.

The Debug Display shows additional information about eMessenger E-mail 
Response activity. To enable/disable this function:

• From the Options menu, click Debug Display.
hapter 8 V.1.63H
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 eMessenger Directory

The eMessenger Directory stores the names and telephone numbers of 
parties frequently called by SpectraLink wireless telephone users.

Setting up the Directory

To set up the eMessenger Directory:

1 From the Edit menu, click Directory.
2 In the eMessenger Directory window, click New.
3 Enter the First Name, Last Name, and Number of the party you want 

to include in the directory.
4 Click Save.

The file may be exported and stored as a backup file. To restore the 
directory, import the backup file.

To Delete an entry in the Directory:

1 Select the entry you wish to delete.
2 Click Delete.
3 Click Yes to confirm the action.

Monitoring System Activity
Disk Logging saves all data to disk. To enable/disable this function:

• From the Options menu, click Disk Logging. 
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When the mldlog.txt file reaches .5 MB, it is saved in the eMessenger Server 
directory with the date in the file name.

Display Debug Data shows additional information about the Directory’s 
operation. To enable/disable this function:

• From the Options menu, click Display Debug Data.

Clearing the Directory Window
To clear the Directory window:

• From the Commands menu, click Clear Screen.
This action clears any output that is currently in the application window. 
Output display automatically continues.
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 eMessenger LAN Client

The eMessenger LAN client, which is installed on any number of client PCs, 
is used to send a text message to a wireless telephone or a pager. All clients 
must be able to communicate with the server by IP address. The Server and 
client do not have to be on the same network, as long as the IP address can 
be reached.

Sending a Message

To send a message from the client computer to a wireless telephone user:

1 Select the recipient’s name from the Name list or select phone number 
from Phone Number or Extension list.

2 Type in message in the Message field or select a pre-defined message.
3 Click Send to send the message.
4 To clear the message, click Clear.
5 Click Exit to close the window.

Updating the Database
The database of valid recipients is maintained on the Server. When the 
eMessenger LAN client program is active and data has been added or 
deleted on the Server database, Update Database button is activated to 
alert the user to download the new database. If the Update Database 
button is inactive, the LAN client’s database is current.
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Setting the eMessenger IP address and sender’s name
The LAN client communicates with the Server by IP address.

To input the correct IP address of the Server:

1 Left mouse click on the LAN Client icon in the upper-left corner of the 
application window.

2 Click Edit Options.
3 Type the IP address of the eMessenger Server.
4 Type the IP address or Name of the Pager Server.
5 Type the User’s From Address (LAN Client User’s name).
6 Click OK.

On each LAN client installation, the sender’s name should be indicated so 
that the recipient knows who sent the message. The sender’s name will 
appear on the wireless telephone at the end of the message. 
hapter 10 V.1.63H
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